The following tables are meant to serve as a quick reference for software compatibility.

Checking the requirements: please make sure that the system meets the following minimum requirements before you start installing Centreon. If you have any question you can get help from Centreon or its partners network, but you can also check online documentation and Centreon forums.

Support and maintenance plans are available through Centreon company and its partners network to guarantee you an excellent quality of service for the resolution of all incidents related to your Centreon environment.

  • Ubuntu / Debian
  • RedHat / CentOS
  • OpenSuse
  • Unix systems
  • Microsoft Internet Explorer 7 and above
  • Mozilla Firefox 2.0 and above
  • Apple Safari 3.x and above
  • Google Chrome
  • Adobe Flash browser plug-in should be installed for some features
  • apache (1.3, 2.0, 2.2)
  • PHP version 5.1 to 5.4
  • PHP extensions :
    • xmlwriter
    • mysql
    • ldap (optional)
  • Pear Libraries
    • DB
    • DB_DataObject
    • DB_DataObject_FormBuilder
    • MDB2
    • Date
    • HTML_Common
    • HTML_QuickForm
    • HTML_QuickForm_advmultiselect
    • HTML_Table
    • Archive_Tar
    • Auth_SASL
    • Console_Getopt
    • Net_Socket
    • Net_Traceroute
    • Net_Ping
    • Validate
    • XML_RPC
    • SOAP
  • MariaDB (5.5-10.1)
  • MySQL (5.1-5.6)
  • SSL certificate should be valid if you access the backend administration platform via SSH.
  • Self-signed SSL certificates are not supported

If you have more questions regarding requirements, please contact Centreon Development team on the forge. You can find also information regarding setup architecture on Centreon documentation. If you have needs not aknowledged in the documentation, please contact us.

Fork me on GitHub